Logo da MMHospedagem
Carregando...
A página de login do Plesk não está acessível: Falha ao descriptografar o atributo 'senha' porque o conjunto de chaves não existe
imprimir
  • 0

Sintomas

A página de login do Plesk mostra uma das seguintes mensagens de erro:

HTTP Error 500.19 - Internal Server Error
Error Code 0x8007000d
Config Error Failed to decrypt attribute 'password' because the keyset does not exist

Keyset does not exist (Exception from HRESULT: 0x80090016)

Causa

Permissões insuficientes nos arquivos:

%ALLUSERSPROFILE%\Microsoft\Crypto\RSA\MachineKeys\6de9cb26d2b98c01ec4e9e8b34824aa2_*
%ALLUSERSPROFILE%\Microsoft\Crypto\RSA\MachineKeys\76944fb33636aeddb9590521c2e8815a_*

Solução

  1. Conecte-se ao servidor Plesk via RDP .

  2. Abra a pasta  %ALLUSERSPROFILE%\Microsoft\Crypto\RSA\MachineKeys. 

    Note: A exibição de arquivos ocultos e arquivos de sistema protegidos deve ser habilitada no Painel de controle do Windows > Opções de pasta.

  3. Encontre arquivos com nomes que começam com 6de9cb26d2b98c01ec4e9e8b34824aa2_ 76944fb33636aeddb9590521c2e8815a_.

  4. Verifique as permissões de acesso nesses arquivos (clique com o botão direito em um arquivo > Propriedades > guia Segurança).

    Aqui estão as permissões corretas:

    Sistema, Administradores, TrustedInstaller - Controle total
    IIS_IUSR, WMSVC - Leia
    LOCAL SERVICE (se disponível) - Leia

 

Se o problema persistir, aplique as seguintes etapas:

  1. Inicie um prompt de comando como administrador .

  2. Obtenha um GUID:

    C:\> reg query "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Cryptography" | findstr MachineGuid
  3. Verifique se os arquivos têm nomes 6de9cb26d2b98c01ec4e9e8b34824aa2_GUID e 76944fb33636aeddb9590521c2e8815a_GUID .

    Exemplo - Se um GUID for:

    C:\> reg query "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Cryptography" | findstr MachineGuid
    MachineGuid REG_SZ 40c6fa54-0d9a-45ae-91c5-e85eb36dcbd2

    então os arquivos terão nomes:

6de9cb26d2b98c01ec4e9e8b34824aa2_40c6fa54-0d9a-45ae-91c5-e85eb36dcbd2
76944fb33636aeddb9590521c2e8815a_40c6fa54-0d9a-45ae-91c5-e85eb36dcbd2

  1. Reinicie o IIS usando o seguinte comando em um prompt de comando:

    C:\> iisreset

Esta resposta lhe foi útil?

Artigos Relacionados

MMHospedagem